Management Portal Temporarily Unavailable

Incident Report for Todyl

Resolved

This incident has been resolved.
Posted Oct 28, 2025 - 21:53 UTC

Monitoring

A brief interruption occurred with the Todyl Management portal, causing temporary unavailability. This has now fully recovered, and all systems are operational. We are actively investigating the root cause to prevent future occurrences.
Posted Oct 28, 2025 - 20:33 UTC
This incident affected: Todyl.com & Management Portal.