SASE reconnections and connection delays

Incident Report for Todyl

Resolved

This incident has been resolved.
Posted Mar 26, 2026 - 04:05 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2026 - 02:35 UTC

Investigating

We are currently investigating elevated device reconnect rates on a subset of SASE nodes. This may result in intermittent connection instability or degraded performance for users connecting through the affected nodes.
Posted Mar 26, 2026 - 02:04 UTC
This incident affected: Secure Global Network (SASE) (Secure Global Network).