SIEM Processing & Alerting — Alert Volume Anomaly

Incident Report for Todyl

Resolved

This incident has been resolved.
Posted May 01, 2026 - 22:14 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 01, 2026 - 21:58 UTC

Investigating

We are currently investigating an anomalous spike in alert volume affecting SIEM Processing & Alerting. Beginning at roughly 19:30 UTC a large number of cases were generated across a portion of partner tenants, associated with endpoint detection activity. The volume of alerts generated is inconsistent with expected baseline behavior.

Our engineering team is actively investigating the issue.
Posted May 01, 2026 - 20:41 UTC
This incident affected: SIEM Processing & Alerting.