Case creation

Incident Report for Todyl

Resolved

Delays in case Creation and reporting issue is resolved.    System and MXDR team is fully up to speed in reviewing the delayed cases.  We are continuing to monitor but we consider the issue resolved.
Posted Apr 28, 2026 - 15:16 UTC

Update

We are continuing to investigate this issue.
Posted Apr 28, 2026 - 13:46 UTC

Update

We are continuing to investigate this issue.
Posted Apr 28, 2026 - 13:33 UTC

Investigating

We identified and resolved an issue that caused delays in case creation and scheduled reporting. No alerts were lost, and MXDR is actively reviewing and addressing all open cases. We are maintaining heightened monitoring until all delayed cases have been fully processed, reviewed, and addressed, and all scheduled reports have been delivered.
Posted Apr 28, 2026 - 13:29 UTC
This incident affected: SIEM Processing & Alerting.