Case Generation Delay

Incident Report for Todyl

Resolved

This incident has been resolved.
Posted Jan 15, 2026 - 20:20 UTC

Monitoring

We have successfully resolved the database replication lag. Case creation has returned to normal speeds, and we are continuing to monitor the environment to ensure sustained stability.
Posted Jan 15, 2026 - 19:29 UTC

Identified

A fix has been deployed for the database lag impacting case creation. Log ingestion remains stable, and we are seeing the processing delay decrease. All backlogged cases will be processed automatically.
Posted Jan 15, 2026 - 18:57 UTC

Investigating

We are currently experiencing a temporary database replication lag which may cause delays in case creation for some tenants. While log ingestion remains fully operational, a subset of detections may experience latency in generating cases. Please be assured that all delayed cases will be fully processed and reviewed as the backlog clears.
Posted Jan 15, 2026 - 18:24 UTC
This incident affected: SIEM Processing & Alerting.