Todyl Portal Load Times
Incident Report for Todyl
Resolved
This incident has been resolved.
Posted Sep 20, 2021 - 14:37 UTC
Investigating
We are currently investigating intermittent load time issues in the management portal.
Posted Sep 20, 2021 - 14:32 UTC
This incident affected: Todyl.com & Management Portal.