SIEM Search and Dashboard Performance Issues

Incident Report for Todyl

Resolved

This incident has been resolved.
Posted May 15, 2025 - 21:10 UTC

Monitoring

We have made changes to address the earlier performance issues affecting SIEM search and dashboards. The system is now functioning as expected.

We are continuing to monitor to ensure full stability.
Posted May 15, 2025 - 20:31 UTC

Investigating

We are currently investigating an issue causing slow performance and intermittent timeouts in SIEM search and dashboard views.

Important: This issue does not impact the underlying protection or detection capabilities.
All detections are continuing to run on time, and systems remain fully protected.

We will provide updates as we work toward resolution. Thank you for your patience.
Posted May 15, 2025 - 18:16 UTC
This incident affected: SIEM Dashboard & Portal.