Slowness in SIEM Search

Incident Report for Todyl

Resolved

This issue has been resolved.
Posted Nov 03, 2025 - 20:12 UTC

Monitoring

We have applied a fix and SIEM search is performing within target parameters. We will continue to monitor the system performance.
Posted Nov 03, 2025 - 19:24 UTC

Identified

SIEM search is currently experiencing degraded performance. While SIEM ingestion continues to operate normally, search queries are experiencing extended response times and occasional timeouts. We have identified the root cause and are actively working on a resolution.

SIEM ingestion, processing and alerting continue to operate as expected.
Posted Nov 03, 2025 - 19:06 UTC
This incident affected: SIEM Dashboard & Portal.