Microsoft API Ingestion Delays

Incident Report for Todyl

Resolved

This incident has been resolved.
Posted Jul 23, 2026 - 20:19 UTC

Monitoring

Microsoft is currently experiencing an incident affecting their M365 API. As a result, O365 data ingestion is delayed, temporarily impacting O365-sourced events. We are monitoring the upstream Microsoft incident and will update as it progresses.
Posted Jul 23, 2026 - 18:38 UTC
This incident affected: SIEM Processing & Alerting.