Misconfiguration in macOS 15.4 Agents

Incident Report for Todyl

Resolved

This issue has been resolved, and systems are now operating as expected.
Posted Apr 25, 2025 - 23:52 UTC

Identified

We have identified an issue affecting a small percentage of agents running on macOS version 15.4, resulting in a misconfiguration. Our team is actively working to deploy a solution to remediate the issue.
Posted Apr 25, 2025 - 18:54 UTC

Investigating

We are currently investigating a potential misconfiguration affecting a subset of agents running on macOS version 15.4. Impacted agents may experience degraded performance, or unexpected behavior.
Our team is actively reviewing logs and configuration data to assess the scope and identify the root cause. At this time, the issue appears to be isolated to macOS 15.4 environments and SIEM features, we do not expect SASE connectivity or performance to be impacted.
Posted Apr 25, 2025 - 16:12 UTC
This incident affected: NGAV/EDR.