Degraded SIEM Loading Issues

Incident Report for Todyl

Resolved

This incident has been resolved. We have been monitoring overnight and throughout today and confirm normal operational state for display of data across dashboards, widgets, and integrations pages within SIEM.
Posted Sep 02, 2026 - 20:42 UTC

Monitoring

A fix for the issue impacting the display of data has been implemented. We will continue to monitor to see if there are any further challenges. We will resolve once fully confirmed.
Posted Sep 01, 2026 - 03:26 UTC

Identified

We continue to experience above-average query volume which is resulting in intermittent delays with data loading into the SIEM. The problem has been identified and we are in the process of implementing changes to alleviate the resource demand. We will provide an update once the changes are implemented.
Posted Aug 31, 2026 - 20:40 UTC

Investigating

We are actively investigating an issue impacting the consistent display of data across dashboards, widgets, and integrations pages within SIEM. Data ingestion is confirmed to be ongoing; however, affected users may experience inconsistent visibility of that data in the noted components. We will update once we have identified the root cause of the issue.
Posted Aug 31, 2026 - 13:00 UTC
This incident affected: SIEM Dashboard & Portal.