Intermittent Slow Page Loads in Management Portal
Incident Report for Todyl
Resolved
This incident has been resolved.
Posted Jan 18, 2024 - 18:49 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 18, 2024 - 18:19 UTC
Identified
The issue has been identified and the team is working on the appropriate fix. An update will be posted in an hour if one is not available sooner.
Posted Jan 18, 2024 - 17:55 UTC
Investigating
We are currently investigating sporadic slow page load times within the Todyl Management Portal. An update will be posted within an hour if one is not available sooner.
Posted Jan 18, 2024 - 16:49 UTC
This incident affected: Todyl.com & Management Portal.