Ingestions delays with O365 logs ingestion

Incident Report for Todyl

Resolved

This incident has been resolved.
Posted Oct 29, 2025 - 22:52 UTC

Monitoring

O365 Event Ingestion is Returning to Normal. We will continue to monitor the situation.
Posted Oct 29, 2025 - 19:52 UTC

Identified

Microsoft services are currently experiencing DNS issues. The log ingestion should resume once the DNS issues on Microsoft side are resolved.
Posted Oct 29, 2025 - 16:55 UTC

Investigating

We are investigating ingestion delays with ingestion of security events from O365. At the moment it only affects O365 events. Other events ingestion is not affected.
Posted Oct 29, 2025 - 16:37 UTC
This incident affected: SIEM Processing & Alerting.