Investigating intermittent URL resolution issue

Incident Report for Todyl

Resolved

This incident has been resolved.
Posted Jul 24, 2026 - 20:46 UTC

Monitoring

A third party provider has implemented a fix that appears to have resolved the intermittent URL failure. We will continue to monitor for any other issues and update here as needed.
Posted Jul 24, 2026 - 14:01 UTC

Investigating

We are currently investigating reports of certain URLs intermittently failing to resolve correctly. Some domains, including those in the Google domain family, may be impacted. Our team is actively investigating and we will provide updates as more information becomes available.
Posted Jul 24, 2026 - 03:35 UTC
This incident affected: Secure Global Network (SASE) (Secure Global Network).