SASE: Intermittent blocks to amazon.com

Incident Report for Todyl

Resolved

This issue has been resolved.
Posted Nov 26, 2025 - 00:20 UTC

Identified

We are currently experiencing an issue where sign-in attempts to amazon.com are being intermittently blocked when routed through SGN. We are working to remediate this issue now.
Posted Nov 25, 2025 - 18:34 UTC
This incident affected: Secure Global Network (SASE) (Secure Global Network).