Increased Errors from Chicago PoP
Incident Report for Todyl
Resolved
This incident has been resolved.
Posted Jan 23, 2021 - 17:51 UTC
Identified
We're currently routing devices to the next nearest and fastest location.
Posted Jan 23, 2021 - 15:54 UTC
This incident affected: Secure Global Network (SASE) (Secure Global Network).