Delays in Management Portal Page Loads
Incident Report for Todyl
Resolved
This incident has been resolved.
Posted Dec 13, 2023 - 22:55 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 13, 2023 - 22:13 UTC
Investigating
We are currently investigating page load delays in the Todyl Management Portal. Other services are not impacted. An update will be made in 30 minutes if one is not available sooner.
Posted Dec 13, 2023 - 22:03 UTC
This incident affected: Todyl.com & Management Portal.