Milan Region Power Failures
Incident Report for Todyl
Resolved
This incident has been resolved.
Posted Jul 16, 2024 - 18:26 UTC
Identified
The team is monitoring power failures impacting availability of the Milan region. The SGN Connect agent will connect to the closest, fastest region. We will provide another update as soon as it become available.
Posted Jul 16, 2024 - 15:21 UTC
This incident affected: Secure Global Network (SASE) (Milan, ITA).